树莓派开启 OverlayFS 后如何持久保存数据?/boot 镜像挂载方案
树莓派开启 OverlayFS 后,根文件系统的写入会转移到内存,重启即丢失。本文介绍一种不额外增加外设的持久化方案:利用 /boot 分区仍可写的特性,在其中创建一个 ext4 磁盘镜像,通过 systemd 的 .mount 单元挂载到 /data。
呐、「我们」还会再见面吗?
树莓派开启 OverlayFS 后,根文件系统的写入会转移到内存,重启即丢失。本文介绍一种不额外增加外设的持久化方案:利用 /boot 分区仍可写的特性,在其中创建一个 ext4 磁盘镜像,通过 systemd 的 .mount 单元挂载到 /data。
本文介绍命令适用于版本为 Debian 13 (trixie) 的Raspberry Pi OS Lite。使用其他版本的小伙伴也可以试试。内容总结了树莓派上 Wi-Fi 的扫描与连接,以及连接配置管理的常用命令。同时提供进阶的脚本控制示例。
在VMware或VBox里,我们可以在虚拟机管理界面为已有的Linux虚拟机磁盘扩展更大的空间。但这些空间对于操作系统来说并不能直接使用。本文介绍如何为系统盘扩容。方法对于RockyLinux、AlmaLinux等RHEL系操作系统来说应该是通用的。
之前介绍了如何[在CentOS 7上编译安装新版Linux内核。我们可以基于目标平台的配置文件在本地编译新内核,然后再移植到目标平台的主机上。本文介绍如何将本地编译的内核移植到其他主机,包括同平台间的移植以及不同平台系统间的移植方法的异同,以及各种注意事项。
之前介绍了如何在CentOS 7上编译安装新版Linux内核。在编译那一步,有些小伙伴可能会在编译到某些模块时遇到“tar: 无法识别的选项”–sort=name””的报错。这是典型的CentOS7自带的老版tar导致的编译失败。最彻底的解决方法就是编译新版本的tar。
自2024年官方彻底抛弃CentOS 7后,其默认Linux内核版本永远定格在了3.10。BBR等一些依赖新内核的特性无法使用,而更换操作系统也不适用于所有环境。本文带你直接下载Linux内核的源码,并用编译源码的方式将CentOS 7内核版本升级至6.6.52。
很多人看到htop显示内存占用很高、Swap被使用就以为系统内存不够了。其实Linux的内存管理机制与Windows完全不同。本文详细解析htop中内存条的颜色含义、Swap为什么会被使用、如何判断是否真的内存不足,并给出实用的排查方法。
用Docker部署WordPress时发现iptables INPUT链无效,外网仍能访问容器。原因是端口映射流量经FORWARD链并进入DOCKER-USER。文章解析了Docker的DNAT机制,并说明应在DOCKER-USER链设置规则,才能有效限制外部访问。
用Nginx反向代理的WordPress,登录后台、查看文章没有问题,投稿一开始也没问题,但在进行了多次投稿(或保存草稿)操作后出现“500 Internal Server Error”,并且错误持续存在。日志中出现了Permission denied,意味着文件权出了问题。
以某软件Resource Sync为例,告诉你如何将二进制或脚本制作为系统服务。我们要创建名为resync.service的服务。按照接下来的步骤做:……不出意外的话这时候服务应该已经启动了。可以用systemctl status resync查看服务状态。